Login | Register
My pages Projects Community openCollabNet

Discussions > users > [argouml-ruby-users] Ruby generation

argouml-ruby
Discussion topic

Hide all messages in topic

All messages in topic

Re: [argouml-ruby-users] Ruby generation

Reply

Author linus
Full name Linus Tolke
Date 2011-12-01 22:13:07 PST
Message Hello Conrad!

The modules, like ruby, that are not included in the standard argouml
release are less mature. This means that there are some extra work involved
in testing them. You need to go to the resources describing how to work and
develop the argouml projects.

In theory you should be able to download a distribution of argouml, get the
source of argouml-ruby, organize them w.r.t. each other and build. Like
this:
* get and unpack the argouml distribution.
* mkdir argouml
* mv argouml-version to argouml/build (so that the jars are in
argouml/build/argouml.jar, ...)
* get argouml-ruby (svn co
http://argouml-ruby.​tigris.org/svn/argou​ml-ruby/trunk argouml-ruby
* Build: cd argouml-ruby; ant install
* Run: cd ../argouml/build; jar -jar argouml.jar

There are many potential problems with this. Let me know how it goes.

         /Linus



2011/12/1 Conrad Taylor <conradwt at gmail dot com>

> Hi, I'm new to Argo UML and I was wondering, how does one install support
> for Ruby generation?
>
> Thanks,
>
> -Conrad
>
> --------------------​--------------------​--------------
>
> http://argouml-ruby.​tigris.org/ds/viewMe​ssage.do?dsForumId=4​951&dsMessageId=​2889468
>
> To unsubscribe from this discussion, e-mail: [
> users-unsubscribe@ar​gouml-ruby.tigris.or​g].
>
Attachments

[argouml-ruby-users] Ruby generation

Reply

Author conradwt
Full name Conrad Taylor
Date 2011-11-30 16:27:39 PST
Message Hi, I'm new to Argo UML and I was wondering, how does one install support for Ruby generation?

Thanks,

-Conrad
Messages per page: